Binding Chaos

Standard

Heather Marsh

The world is long overdue for a completely new system of governance.

If there was ever a need for political representation or a paternalistic and opaque authority it has been removed by technology. Every political system we have tried has proven incapable of protecting human rights and dignity. Every political system we have tried has devolved into oligarchy. To effect the change we require immediately, to give individuals control and responsibility, to bring regional systems under regional governance, allow global collaboration and protect the heritage of future generations, we need a new political model.

Amazon
CreateSpace store
Binding Chaos PDF 6 X 9
Binding Chaos PDF 8.5 X 11
Enlazando Caos Spanish, thanks very much to Sandra Bit (@ebitlution) for translation.
ePub version thanks very much to Kevin Beynon

Share in any way you like with attribution (CC BY-NC-SA 3.0). Linkback to here if possible.

Pay what you feel is…

View original post 70 more words

Advertisements

Script IP Dinamis di MikroTik

Standard

Sejak ROS mengalami beberapa kenaikan versi sudah menjadi sunatullah bahwasannya beberapa fitur juga akan mengalami penyesuaian (baca=ikut-ikutan berubah juga :-D), dalam kasus ini termasuk Script IP Dinamis.

SakroTik

DynDNS

:local DDNSuser "login"
:local DDNSpass "password"
:local DDNShost "domain.dyndns.info"

:local CURRip [/tool fetch url="http://myip.dnsomatic.com/index.html" mode=http dst-path=CURRip; :delay 1; /file get CURRip contents; /file remove CURRip]
if ([:resolve $DDNShost] != $CURRip) do={
    /tool fetch url="http://members.dyndns.org/nic/update?hostname=$DDNShost&myip=$CURRip" mode=http user=$DDNSuser password=$DDNSpass dst-path=DDNShost keep-result=no;
    /log info message=("DDNS: Updating $DDNShost to:$CURRip")
    }

 

NO-IP

:local DDNSuser "login"
:local DDNSpass "password"
:local DDNShost "domain.no-ip.com"

:local CURRip [/tool fetch url="http://myip.dnsomatic.com/index.html" mode=http dst-path=CURRip; :delay 1; /file get CURRip contents; /file remove CURRip]
if ([:resolve $DDNShost] != $CURRip) do={
    /tool fetch url="http://dynupdate.no-ip.com/nic/update?hostname=$DDNShost&myip=$CURRip" mode=http user=$DDNSuser password=$DDNSpass dst-path=DDNShost keep-result=no;
    /log info message=("DDNS: Updating $DDNShost to:$CURRip")
    }

 

ChangeIP

:local DDNSuser "login"
:local DDNSpass "password"
:local DDNShost "domain.changeip.com"

:local CURRip [/tool fetch url="http://myip.dnsomatic.com/index.html" mode=http dst-path=CURRip; :delay 1; /file get CURRip contents; /file remove CURRip]
if ([:resolve $DDNShost] != $CURRip) do={
    /tool dns-update name=$DDNShost address=$CURRip key-name=$DDNSuser key=$DDNSpass
    /log info message=("DDNS: Updating $DDNShost to:$CURRip")
    }

Memungkinkan untuk digunakan di Dyn.com, NoIP, ChangeIP

:local DDNSuser value="login";
:local DDNSpass value="password";
:local DDNShost value="domain.dyndns.info";

# possible value are DynDNS, No-IP, ChangeIP;
:local DDNStype value="DynDNS";

/tool fetch mode=http keep-result=yes url="http://myip.dnsomatic.com/index.html" dst-path="CURRip";
/delay delay-time=2s;
:local CURRip value=[:toip [/file get "CURRip" value-name=contents]];
/delay delay-time=2s;
/file remove "CURRip";

:if ([:resolve $DDNShost] != $CURRip) do={
 :if ($DDNStype = "DynDNS") do={ /tool fetch mode=http keep-result=no url="http://members.dyndns.org/nic/update?hostname=$DDNShost&myip=$CURRip" user=$DDNSuser password=$DDNSpass; };
 :if ($DDNStype = "No-IP") do={ /tool fetch mode=http keep-result=no url="http://dynupdate.no-ip.com/nic/update?hostname=$DDNShost&myip=$CURRip" user=$DDNSuser password=$DDNSpass; };
 :if ($DDNStype = "ChangeIP") do={ /tool dns-update name=$DDNShost address=$CURRip key-name=$DDNSuser key=$DDNSpass; };
 /log info message=($DDNStype.": Updating ".$DDNShost." to:".$CURRip);
};

 

Fitur di bawah ini memungkinkan juga untuk diimplementasikan:

:local CURRip [/tool fetch url="http://myip.dnsomatic.com/index.html" mode=http dst-path=CURRip keep-file=no;]

dibandingkan dengan script seperti di bawah ini:

:local CURRip [/tool fetch url="http://myip.dnsomatic.com/index.html" mode=http dst-path=CURRip; :delay 1; /file get CURRip contents; /file remove CURRip]

ada juga beberapa versi script yang diimplementasikan oleh beberapa MikroTik expert, misalnya, seperti di bawah ini:

:global scriptemail
:global ddnsurl1
:global ddnsurl2
:local wanipchecklast
:local wanipchecknow
:local wanipchanged "no"
:local ddnsuser "user"
:local ddnspass "passwd"
:local ddnshost1 "domain1.blablabla.in"
:local ddnshost2 "domain2.blablabla.to"
:log info "********************getting run - ddns********************"
:log info "-"
/tool fetch url="http://www.ipmon.co.za/ip.php" dst-path="ddns_my_public_ip.txt"
:log info "checkking for wan ip address"
:set wanipchecklast [/ip firewall address-list get value-name=comment number=[find list="My-Public-IP"]]
:set wanipchecknow "$[/file get "ddns_my_public_ip.txt" contents] "
:log info "current wan ip address: $wanipchecknow"
:log info "prevouis wan ip address: $wanipchecklast"
:log info "$[/system identity get name] wan ip address http://$wanipchecknow"
:if ($wanipchecknow != $wanipchecklast) do={
:log info "wan ip address has chaged"
:set wanipchanged "yes"
/ip firewall address-list set comment=$wanipchecknow number=[find list="My-Public-IP"]
:log warning "$[/system identity get name] wan ip address changed: $wanipchecklast -> $wanipchecknow"
:log info "updateing ddns host $ddnshost"
/tool fetch mode=http user=$ddnsuser password=$ddnspass url="http://dynupdate.no-ip.com/nic/update\3Fhostname=$ddnshost1&myip=$wanipchecknow" dst-path="ddns update result.txt" keep-result=yes
:delay 15s;
/tool fetch mode=http user=$ddnsuser password=$ddnspass url="http://dynupdate.no-ip.com/nic/update\3Fhostname=$ddnshost2&myip=$wanipchecknow" dst-path="ddns update result.txt" keep-result=yes
:set ddnsurl1 "http://dynupdate.no-ip.com/nic/update\3Fhostname=$ddnshost1&myip=$wanipchecknow"
:set ddnsurl2 "http://dynupdate.no-ip.com/nic/update\3Fhostname=$ddnshost2&myip=$wanipchecknow"
:log info "ddns result: $[/file get "ddns update result.txt" contents] "
}
:if ($wanipchanged = "yes") do={
:log info "generating ddns email report"
:global scriptemail
:local logcontenttemp ""
:local logcontent ""
:set logcontenttemp "Good Day \n\r"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "This is an automated notification, please do not reply to this email"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "Please see below ddns update email report: \n\r"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "*****************************************ddns report***********************************"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "Current wan ip address: $wanipchecknow \n\r"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "Prevouis wan ip address: $wanipchecklast \n\r"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "Update url: $ddnsurl1 \n\r"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "Update url: $ddnsurl2 \n\r"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "Update url result: $[/file get "ddns update result.txt" contents] \n\r"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "\n\r"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "***************************************************************************************"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "KEY: \n\r"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "Should you have any queries, please contact your account manager"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "\n\r"
:set logcontent ("$logcontent
" ."$logcontenttemp")
:set logcontenttemp "Kind Regrads"
:set logcontent ("$logcontent
" ."$logcontenttemp")
/tool e-mail send to=$scriptemail subject="$[/system identity get name] ddns report" body="$logcontent" start-tls=yes
}
:log info "******************** ending - ddns ********************" 

Lalu tambahkan rule berikut:

/ip firewall address-list add comment="" address="0.0.0.0" list="My-Public-IP"

Semoga Bermanfaat

Sumber

 

 

Standard

Life is a journey, and the ultimate goal of our journey is happiness. In life, more or less everything we do is for happiness. To start a journey, a clear destination is needed, so that we can follow and get to the right destination. Without a clear destination, we go round and round and back to the same point, or the journey will cause us a lot of trouble. “What is our destination” is the proper question to ask ourselves right here and now.

“Life is a journey, begin for one ROAD… but never finished until a million ROUTES”
#JourneyHasBegun #Resolution2016

View on Path

Standard

Katakan dengan jujur, walaupun itu PAHIT, pahit untuk yang mengungkapkan, juga bisa pahit terasa bagi yang diberi pengungkapan. Adalah karena aq tak “Panjang LIDAH” maklum jikalau kurang pinter “MENJILAT”!. Dan ternyata “PANJANG Akal” dan “pandai MELAYANI” belum tentu CUKUP, namun demikian hidup ini indah koq 🙂 #LidahSepanjangJalan

View on Path

Pria CAKAP

Quote

Karena salah satu ciri PRIA yang CAKAP, itu bukan saja “good looking” buat dipandang kemudian “easy listening” kalo dia ngomong, tetapi yang tak kalah penting juga harus memiliki “jemari yang nakal” (good-typing or good-taping but not best fingering) = SOPAN meNULISkan apa yang HENDAK diSAMPAIkan serta “lidah yang nakal” pula (better speaking but not expert-licking) SANTUN meLISANkan apa yang ia keHENDAKi.